What are the requirements for using a QR code sticker?

Your TWINT app needs to be up to date in order to execute payments via QR code stickers. If your app isn’t up to date, you will need to download the latest version.

Was this answer helpful?

Thank you for your feedback!

FAQ Feedback
Thank you for your feedback!

Please tell us why the answer to the question did not solve your problem.

Important: You will receive no reply to your message. For support requests, please contact the TWINT Support team at your bank.

Go to top of page